changeset 0:35b72dc38da1

Initial revision
author Guido Berhoerster <guido+packaging@berhoerster.name>
date Wed, 09 Jan 2013 17:34:41 +0100
parents
children 0ce833e3c661
files feed2imap-rubygem-compatibility.patch feed2imap.spec sources
diffstat 3 files changed, 102 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/feed2imap-rubygem-compatibility.patch	Wed Jan 09 17:34:41 2013 +0100
@@ -0,0 +1,36 @@
+Index: feed2imap/lib/feed2imap/feed2imap.rb
+===================================================================
+--- feed2imap.orig/lib/feed2imap/feed2imap.rb
++++ feed2imap/lib/feed2imap/feed2imap.rb
+@@ -21,6 +21,7 @@ Foundation, Inc., 59 Temple Place, Suite
+ F2I_VERSION = '1.0'
+ F2I_WARNFETCHTIME = 10
+ 
++require 'rubygems'
+ require 'feed2imap/config'
+ require 'feed2imap/cache'
+ require 'feed2imap/httpfetcher'
+Index: feed2imap/lib/feed2imap/itemtomail.rb
+===================================================================
+--- feed2imap.orig/lib/feed2imap/itemtomail.rb
++++ feed2imap/lib/feed2imap/itemtomail.rb
+@@ -19,6 +19,7 @@ along with this program; if not, write t
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+ =end
+ 
++require 'rubygems'
+ require 'rexml/document'
+ require 'time'
+ require 'rmail'
+Index: feed2imap/lib/feed2imap/rexml_patch.rb
+===================================================================
+--- feed2imap.orig/lib/feed2imap/rexml_patch.rb
++++ feed2imap/lib/feed2imap/rexml_patch.rb
+@@ -17,6 +17,7 @@ along with this program; if not, write t
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+ =end
+ 
++require 'rubygems'
+ require 'feedparser'
+ 
+ # Patch for REXML
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/feed2imap.spec	Wed Jan 09 17:34:41 2013 +0100
@@ -0,0 +1,65 @@
+%global ruby_sitelib %(ruby -rrbconfig -e "puts Config::CONFIG['sitelibdir']")
+%global snapshot 20130109
+
+Name:           feed2imap
+Version:        1.0
+Release:        1.%{snapshot}git%{?dist}
+Summary:        RSS/Atom Feed Aggregator Using an IMAP Server or Maildir for Storage
+
+Group:          Applications/Internet
+License:        GPLv2+
+URL:            http://home.gna.org/feed2imap/
+# git clone git://github.com/ln/feed2imap.git; tar -cjf feed2imap-$(date +%%Y%%m%%d).tar.bz2 --exclude-vcs feed2imap
+Source0:        %{name}-%{snapshot}.tar.bz2
+# make feed2imap compatible with rubygem versions of ruby-feedparser and rmail
+Patch0:         feed2imap-rubygem-compatibility.patch
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch:      noarch
+
+BuildRequires:  ruby(abi) = 1.8
+BuildRequires:  ruby
+Requires:       ruby(abi) = 1.8
+Requires:       ruby
+Requires:       rubygem(ruby-feedparser) >= 0.7
+Requires:       rubygem(rmail) >= 1.0.0
+
+%description
+feed2imap is an RSS/Atom feed aggregator. After Downloading feeds (over HTTP or
+HTTPS), it uploads them to a specified folder of an IMAP mail server, or copies
+them to a local maildir. The user can then access the feeds using a mail user
+agent.
+
+%prep
+%setup -q -n %{name}
+%patch0 -p1
+
+%build
+ruby setup.rb config
+
+%install
+rm -rf %{buildroot}
+ruby setup.rb install --prefix=%{buildroot}
+rm -rf %{buildroot}%{_datadir}/doc
+
+%clean
+rm -rf %{buildroot}
+
+%files
+%defattr(-,root,root,-)
+%doc ChangeLog README COPYING data/doc/feed2imap/examples/feed2imaprc
+%{_bindir}/feed2imap-opmlimport
+%{_bindir}/feed2imap
+%{_bindir}/feed2imap-dumpconfig
+%{_bindir}/feed2imap-cleaner
+%{ruby_sitelib}/feed2imap.rb
+%dir %{ruby_sitelib}/feed2imap
+%{ruby_sitelib}/feed2imap
+%{_mandir}/man5/feed2imaprc.5*
+%{_mandir}/man1/feed2imap-cleaner.1*
+%{_mandir}/man1/feed2imap.1*
+%{_mandir}/man1/feed2imap-dumpconfig.1*
+%{_mandir}/man1/feed2imap-opmlimport.1*
+
+%changelog
+* Wed Jan 09 2013 Guido Berhoerster <guido+packaging@berhoerster.name> - 1.0-1.20130109
+- Initial packaging
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sources	Wed Jan 09 17:34:41 2013 +0100
@@ -0,0 +1,1 @@
+20a310a3792e0e309cf0c1443928cba3 feed2imap-20130109.tar.bz2