diff uwsgi.spec @ 4:851739edafa6

Update to version 1.9.21.1
author Guido Berhoerster <guido+packaging@berhoerster.name>
date Wed, 18 Dec 2013 21:01:23 +0100
parents 8f3c148d4f0d
children e6b2af6272a4
line wrap: on
line diff
--- a/uwsgi.spec	Mon Sep 09 19:21:35 2013 +0200
+++ b/uwsgi.spec	Wed Dec 18 21:01:23 2013 +0100
@@ -1,13 +1,13 @@
 # revision of the uwsgi documentation corresponding to the packaged release
-%global uwsgi_docs_rev  63bde22cd047e8ff0da9bbb98d2ad2cdf9be2d5a
+%global uwsgi_docs_rev  eaf1ca90a65ab8524c565fa1bd783838b5dba738
 
 Name:           uwsgi
-Version:        1.9.15
+Version:        1.9.21.1
 Release:        1%{?dist}
 Summary:        Complete Stack for Building Clustered/Distributed Network Applications
 
 Group:          System Environment/Daemons
-License:        GPLv2+
+License:        GPLv2+ with exceptions
 URL:            http://projects.unbit.it/uwsgi
 Source0:        http://projects.unbit.it/downloads/%{name}-%{version}.tar.gz
 Source1:        https://github.com/unbit/uwsgi-docs/archive/%{uwsgi_docs_rev}.zip
@@ -21,12 +21,14 @@
 Patch1:         uwsgi-no-rpath.patch
 # link against libboost*-mt provided by RHEL/Fedora
 Patch2:         uwsgi-link-against-boost-mt.patch
+# set libffi CFLAGS and LIBS correctly from pkg-config
+Patch3:         uwsgi-libffi-fix-cflags-libs.patch
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 BuildRequires:  boost-devel
 BuildRequires:  bzip2-devel
+BuildRequires:  ceph-devel
 BuildRequires:  dos2unix
-BuildRequires:  erlang
 BuildRequires:  gcc-objc
 BuildRequires:  GeoIP-devel
 BuildRequires:  gloox-devel
@@ -35,9 +37,13 @@
 BuildRequires:  java-devel
 BuildRequires:  krb5-devel
 BuildRequires:  libattr-devel
-BuildRequires:  libcap-devel
+# POSIX capabilities are disabled because libcap < 2.17 breaks the inclusion of
+# kernel headers (see
+# http://lists.unbit.it/pipermail/uwsgi/2013-December/006800.html)
+#BuildRequires:  libcap-devel
 BuildRequires:  libcurl-devel
 BuildRequires:  libedit-devel
+BuildRequires:  libffi-devel
 BuildRequires:  libuuid-devel
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
@@ -249,6 +255,15 @@
 The python uWSGI plugin embeds Python and allows to run WSGI applications and
 provides access to the uWSGI API from Python.
 
+%package plugin-rados
+Summary:        uWSGI Plugin for Serving Objects Stored in a Ceph Cluster through RADOS
+Group:          Development/Libraries
+Requires:       %{name} = %{version}-%{release}
+
+%description plugin-rados
+The rados uWSGI plugin allows serving objects stored in a Ceph cluster by
+directly accessing RADOS.
+
 %package plugin-rack
 Summary:        uWSGI Plugin Providing Ruby Rack Support
 Group:          Development/Libraries
@@ -338,6 +353,7 @@
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 pushd uwsgi-docs-%{uwsgi_docs_rev}
 # remove empty files
@@ -382,6 +398,10 @@
 blacklist_plugins="${blacklist_plugins} rbthreads"
 # needs glusterfs >= 3.4
 blacklist_plugins="${blacklist_plugins} glusterfs"
+# tcc is not available
+blacklist_plugins="${blacklist_plugins} libtcc"
+# libmatheval is not available
+blacklist_plugins="${blacklist_plugins} matheval"
 
 embed_plugins="null"
 
@@ -434,7 +454,7 @@
 export CFLAGS="%{optflags} -Wno-unused-but-set-variable -Wno-error"
 
 # build uwsgi executable and plugins
-python uwsgiconfig.py --build fedora.ini
+python uwsgiconfig.py --verbose --build fedora.ini
 
 # build apache module
 pushd apache2
@@ -555,21 +575,32 @@
 %{_libdir}/%{name}/carbon_plugin.so
 %{_libdir}/%{name}/emperor_amqp_plugin.so
 %{_libdir}/%{name}/emperor_zeromq_plugin.so
-%{_libdir}/%{name}/erlang_plugin.so
 %{_libdir}/%{name}/fastrouter_plugin.so
+%{_libdir}/%{name}/forkptyrouter_plugin.so
 %{_libdir}/%{name}/gevent_plugin.so
 %{_libdir}/%{name}/graylog2_plugin.so
 %{_libdir}/%{name}/greenlet_plugin.so
 %{_libdir}/%{name}/jwsgi_plugin.so
+%{_libdir}/%{name}/libffi_plugin.so
+%{_libdir}/%{name}/logpipe_plugin.so
 %{_libdir}/%{name}/logsocket_plugin.so
+%{_libdir}/%{name}/logzmq_plugin.so
 %{_libdir}/%{name}/mongodblog_plugin.so
+%{_libdir}/%{name}/mongrel2_plugin.so
+%{_libdir}/%{name}/msgpack_plugin.so
 %{_libdir}/%{name}/nagios_plugin.so
-%{_libdir}/%{name}/pyerl_plugin.so
 %{_libdir}/%{name}/redislog_plugin.so
 %{_libdir}/%{name}/ring_plugin.so
+%{_libdir}/%{name}/router_metrics_plugin.so
 %{_libdir}/%{name}/router_spnego_plugin.so
 %{_libdir}/%{name}/rrdtool_plugin.so
 %{_libdir}/%{name}/servlet_plugin.so
+%{_libdir}/%{name}/stats_pusher_file_plugin.so
+%{_libdir}/%{name}/stats_pusher_socket_plugin.so
+%{_libdir}/%{name}/tornado_plugin.so
+%{_libdir}/%{name}/transformation_template_plugin.so
+%{_libdir}/%{name}/tuntap_plugin.so
+%{_libdir}/%{name}/zabbix_plugin.so
 
 %files doc
 %defattr(-,root,root,-)
@@ -647,6 +678,10 @@
 %defattr(-,root,root,-)
 %{_libdir}/%{name}/rack_plugin.so
 
+%files plugin-rados
+%defattr(-,root,root,-)
+%{_libdir}/%{name}/rados_plugin.so
+
 %files plugin-router_access
 %defattr(-,root,root,-)
 %{_libdir}/%{name}/router_access_plugin.so
@@ -685,6 +720,12 @@
 %{_libdir}/httpd/modules/mod_uwsgi.so
 
 %changelog
+* Wed Dec 18 2013 Guido Berhoerster <guido+packaging@berhoerster.name> - 1.9.21.1-1
+- Update to version 1.9.21.1
+- License change to GPLv2+ with exceptions
+- Disable POSIX capabilities because libcap < 2.17 breaks the inclusion of kernel
+  headers
+
 * Mon Sep  9 2013 Guido Berhoerster <guido+packaging@berhoerster.name> - 1.9.15-1
 - Update to version 1.9.15